在8月17号后,Nginx的仓库签名和Linux发行版的软件包的GPG密钥到期,无法使用。
官方将密钥有效期延长到2024年06月14日,密钥的 ID 保持不变

Debian/Ubuntu用户执行更新命令后会出现如下错误:
W: GPG error: http://nginx.org jessie Release: The following signatures were invalid: KEYEXPIRED 1471427554

处理方法:
Debian/Ubuntu:
wget https://nginx.org/keys/nginx_signing.key && apt-key add ./nginx_signing.key

CentOS/RHEL/SLES:
wget https://nginx.org/keys/nginx_signing.key && rpm --import ./nginx_signing.key